Jump to content
Storyist Forums
garymunroe

Import RTF into Storyist and keep italics?

Recommended Posts

I am switching to Storyist and am trying to get my book imported with the italics intact. I exported the book in RTF format from Jer's Novel Writer.

 

The italics all seem to be in place when I view the RTF in Bean or LibreOffice, but when I import it into Storyist they are gone. I have both created a new document and imported the RTF, and have tried File > Open and imported from there, but no italics. Is there some way to do this?

Share this post


Link to post
Share on other sites

Hi Gary,

 

Storyist should import italics just fine. I've not seen the RTF that Jer's produces. If you'd like, you could post an RTF file with a few paragraphs of text (it could be lorem ipsum), and I'd be happy to take a look.

 

Also, if you happen to have a copy of Word, you could try this:

  1. Open the RtF file in Word.
  2. Make a slight change.
  3. Save the file.
  4. Open the RTF file in Storyist.

Another thing you could try is to switch the RTF that Storyist uses to the OS X importer. To do this:

  1. Launch Storyist.
  2. Open the Preferences window and click the Plugins icon.
  3. Make sure the Importers tab is selected.
  4. Change the RTF importer from "Storyist RTF Importer" to "OS X Importer."

The OS X RTF importer won't read style sheets or headers/footers, but I don't think Jer's exports those things.

 

-Steve

Share this post


Link to post
Share on other sites

Hi Steve,

 

Thank you for your help!

 

First, I tried your suggestion to change the preferences to OSX importer but it did not keep the italics on the import.

 

Then I opened the RTF I had exported from Jer's in LibreOffice (I don't have MSWord), added a small amount of text, Saved-As RTF, and when I imported that RTF to Storyist, the italics were there--yay!

 

Unfortunately, the chapters were not there. I realized the Storyist import dialogue box was different:

 

When I import the RTF I exported from Jer's, step one of three in the Storyist Import Assistant window is "Apply Styles by Matching Text", and the resultant import is divided into chapters using the word "Chapter", but no italics are imported.

 

When I import the RTF I saved from LibreWriter, step 1 of three is: "Replace Styles", and despite selecting Chapter from the different choices the resultant import is not divided into chapters--except in Normal, where every sentence becomes a chapter.

 

I assume this is a styles issue and I could go through and change each Chapter title to a heading style manually, but this is a 230K word book with 64 chapters and I was hoping I wouldn't have to do that.

 

Attached are the small, test RTFs I exported from Jer's Novel Writer and modified in LIbreWriter.

 

italics test.rtfitalics test 2.rtfitalics test 3.rtf

Share this post


Link to post
Share on other sites

PS: Why three RTFs:

 

Italcs test.rtf was exported from Jer's.

 

italics test 2.rtf -- I added some text and Saved-as RTF in LibreWriter.

 

italics test 3.rtf -- I noticed when I opened the Jer's exported RTF in LIbreWriter that the regular font was Courier and the italic font was Courier-Oblique, so I Selected-All in LibreWriter and changed the font in this version to Courier New.

Share this post


Link to post
Share on other sites

Hi Gary,

 

I think I see what is going on. If you were using "Apply Styles by Matching Text" and didn't change the defaults, you were applying the Section Text style to all text that wasn't a chapter title or a section separator. The Section Text style does not have italics set.

 

You usually see the "Apply Styles by Matching Text" option in the import assistant if the imported file does not contain a style sheet (and it looks like Jer's doesn't export style sheets). If, however, your imported files DOES contain a style sheets (as the LibreWriter RTF file does), you instead see the more powerful Replace Styles option.

 

So... if you don't use the import assistant (or at least the "Apply Style by Matching Text" option), you won't overwrite the italics in your file. The easiest way to do this is:

  1. Create a new project.
  2. Drag the Jer's RTF file to the Project view.
  3. When Storyist asks what type you want to create, choose Novel, which will add the Novel stylesheet to your file (since it doesn't already have one).
  4. Click on your imported file in the Project view. It should look exactly as it does in Jer's or Text Edit. (see the attached screenshot)

You can use the Format > Style > Apply Styles by Matching Text command at this point to apply the Chapter Title style if you want. Just remove the "*" pattern that applies Section Text.

 

ItalicsInImportedRTF.png

 

-Steve

Share this post


Link to post
Share on other sites

Steve--Thank you! That worked great. I imported it as you said and the italics were intact. I then used the Format > Apply Styles by Matching Text command. I clicked the minus button and removed the asterisk-Section Text line. It then split it into chapters and retained the italics.

 

Hoo-Rah!

 

Thank you for your time on this. I hope I haven't made you give me information I should be getting from the manual...if so, pardon my ignorance, and thank you once again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...