Jump to content
Storyist Forums
Sarah L

Unable to use the Tab Key on MacBook

Recommended Posts

I am unable to use the tab key in Storyist.  I've already gone into Preferences and turned off 'Enable Key Shortcuts', but it doesn't seem to have made a difference.  I just want to be able to use the tab key like you would in Pages or Microsoft Word.  

I've thought of uninstalling Storyist completely and reinstalling, but I'm afraid I'll have to buy it again if I do that.  Does anyone have any suggestions?  

Share this post


Link to post
Share on other sites

Hi Sarah,

Welcome to the forums.

By default, Storyist uses the tab key to change styles. The default novel template sets a first line indent so you don't need to tab to indent the first line in a paragraph.

You can easily turn this off, though. Just open the Text Editing pane in Preferences window and uncheck the "Enable Tab key shortcuts" checkbox. You can turn this setting on and off on a per-file basis too. Open the File Info inspector (View > Inspector > File Info), locate the Shortcuts section, select the "Use the following values" radio button and update the "Enable tab key shortcuts" checkbox to reflect your choice.

-Steve

Share this post


Link to post
Share on other sites

Thank you!  I'm not sure what the problem is, but I have tried that and it hasn't made a difference.  I'm not sure if my program is glitching or not, but I've restarted both it and my laptop and it hasn't made a difference.  If I uninstalled the whole program would it make me buy it again to reinstall it?  

Share this post


Link to post
Share on other sites

Hi Sarah,

Uninstalling the program probably won't help, though you wouldn't have to buy it again if you did.

Here are some things to check:

  1. Make sure the Preferences > Text Editing > "Enable tab key shortcuts" checkbox is unchecked. (It sounds like you've done this already.)
  2. In the file you're editing, make sure the Inspectors > File Info > Shortcuts > "Use application preferences" radio button is selected.
  3. Make sure your text file has tab stops set. The easiest way to check this is to open the Format inspector and look at the Tabs area.

If you're still not able to use tab stops, please post a screenshot of the Text Editing preferences window and the File Info and Format inspectors. If you'd like, I'd be happy to take a look at the file for you. If you'd like me to do that, please send it to the support address.

-Steve

Share this post


Link to post
Share on other sites

Thank you so much!!!  That fixed it!  I didn't know I needed to set stops for the tab and now it works great!!  Thank you so much for all your help!  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×