Jump to content
Storyist Forums
versluis

Storyist 4.1.x updated itself to a version I cannot run anymore

Recommended Posts

Hi Steve,

I've just picked up Storyist on my old MacBook Pro again. it can't run anything higher than High Sierra. So I launch Storyist 4.1.2 (I think) and get a prompt that a new version is available. Excited by the release notes I hit "Update and relaunch", only to find that I can no longer use it as it requires a newer version of macOS that my hardware does not support.

Please add a check to this process so users have a chance to say no. As it stands, I can no longer use Storyist 4 on this hardware.

Is there a release archive somewhere that allows me to use the latest compatible version for High Sierra?

Share this post


Link to post
Share on other sites

Hi Jay,

Thanks for the feedback. The release notes for version 4.2 had a notice in red that describes the requirements, but it looks like it's missing from 4.2.2.

You'll should find your original version in the trash. You can also get version 4.1.3 from the downloads page at https://www.storyist.com/downloads/.

-Steve

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...