Jump to content
Storyist Forums

New trial user toying up storyist vs scrivener

Recommended Posts


I've got 60 pages into a novel using word and need to sort out better software, obviously.


After spending a fair bit of time looking at what's out there I've got it down to Storyist vs Scrivener.

I'm currently running the Storyist demo and here are my thoughts after a couple of days:


What I really really like about Storyist

- ability to work in compiled view. You nailed it. (scrivener no)

- lovely full screen look, paper texture. Classy. Well done people. (scrivener no)

- simple layout, uncluttered, not trying to be everything to all men. (scrivener ...)


What is bugging me about Storyist

- very limited control of zoom function. Why no ability to adjust in percentages (even Word has this)? This could be a clincher for me as with the current controls I can't get a comfortable size text for how I have my macbook setup as a workstation. People who write for long periods each day need more fine tuning of this important ergonomic. Please tell me I'm wrong and that you have more controls on zoom hidden somewhere?!

- adding sections is buggy?

When I add a section using the pop up window in the bottom left corner, it adds the section sheet all fine but in the document it then positions the curser as centre justified, almost like it would for a title. Why? All subsequent text goes back to the default left justified. Why this extra centre justified line added? I just waste time having to delete it.

The other way I have tried to add sections is by using the window that automatically pops up in the document if you press enter twice in a row, making it clear I suppose that you want a section break - the little window pops up and I press enter again when "section separator" is highlighted but it doesn't work. It doesn't add the section sheet or the hash separator and just positions the curser and text for the next line as centre justified. Proceeding text goes back to left justified. Weird. This double enter way of getting a section break would be great if it worked but it doesn't at the moment for me. I'm using Storyist 2.4.6 on a mac 10.6.

I may be doing it wrong so all suggestions as to the best and simplest way to add section breaks much appreciated.


Anyway I hope this doesn't come across as a whinge - I just wanted to see if these issues are easily resolved by people in the know. If I can resolve the zoom and the section break bugs - I'm sold. If not, it's a bit of feedback : )

Link to post
Share on other sites

Hi, Strang, and welcome to the forums,

There are several easy ways to add a section. The simplest is while typing:


Paragraph 1 text


Paragraph 2 text


You can select the # and apply the Section Separator style, but the new section is already there.


I'm not sure why you're seeing the centered text when you add a section: I don't see that behavior, no matter how I add it. Could you be adding chapters instead?


Another quick way to add a section is to click on the section name above where you want the new section to appear, and type Command+Enter. That adds the section and the section separator at the same time. Clicking + at the bottom left and choosing New Section does the same. So does holding down the Option key and clicking the + at the bottom left.


It looks as if percentage zooms went missing when Steve cleaned up the interface in version 3; new users were getting confused by the many options. If that's true, he may bring them back if you make a feature request. My screen's always set to 200%, so I hadn't even noticed that it's now set to Zoom In/Zoom Out (could also be an Apple directive, now that I think of it).



Link to post
Share on other sites

Hi Marguerite,

Thanks so much for your help.

Adding sections is really not working as it should. Here's a screenshot by screenshot of me trying to add a new section using the + symbol at the bottom left corner/ the "Add a new project item of the same type as the selected item" function. I first highlight the last section I'm working on:


Then I press the + sign in the bottom left hand corner and this happens - I get a section symbol in the manuscript but no section sheet in the left sidebar, also it is two lines down (not a biggie but still another thing to sort out):


Then I have to click inside the manuscript, which you can see is automatically centre justified. I think it is getting confused with adding chapters (which works perfectly):


I type and it's centre justified and then suddenly the section sheet appears in the left sidebar:


Entering and moving onto the next line give me left justified as normal:



Just messed up.


Also the shortcut for adding a new section quoted down in the same left hand corner under the "settings" cog looking thing is "command key" then "enter". This doesn't do anything.

Link to post
Share on other sites

Because in this case you added a Section Separator, I'm guessing. Click on dressing room in the lefthand column, say, then Command-Enter. See what happens.


When I add a section, it does work as it should. (Don't take this the wrong way, please. I have been using the program since 2007.) So the problem is not in the program but how to make the program clearer to people encountering it for the first time.



Link to post
Share on other sites

Hi -


I also came to Storyist from MS Word (and to that after a whole variety of text editors and word processors...)


Zoom: like Marguerite, I have my interface pretty much set up in a way that works for me, so I don't change it much - but zooming in and out of a manuscript text is really easy with a touchpad pinch in/out - Storyist reports the % zoom so you can aim for a particular number, but will probably just leave it at whatever looks right.


Sections: as Marguerite says (and you'll find by searching this forum that she often provides excellent advice, based on experience), just hit return for a new line, type #, then return for a new line and start typing again and you'll be in a new section. I'll usually pause at this point, apply the section separator style (Format > Style > Apply Style) to the #, before resuming my writing. At some point I'll give the section a name in the project view in the left-hand pane - which, given my complete failure to properly plan or storyboard anything (except in my head), is how I keep track of what happens where.


I don't remember ever using the '+' button, except perhaps to try it out. I don't know whether Steve (the creator/coder of Storyist) will want to comment on whether this button is working as it should, but either way it is perfectly possible to use Storyist efficiently without it.



Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...