Jump to content
Storyist Forums
Sign in to follow this  

Missing Text

Recommended Posts

Hey everyone,


A few months ago a scene I had written on the screenplay option went missing. (As if it never saved.)

Storyist hasn't saved any of the changes I've made in the screenplay the last four days.

Has anyone else had this problem too?

I even exported to Dropbox in the hopes of keeping my work safe but the Dropbox version also remains unchanged.

Any thoughts and suggestions will be help, as it's a struggle to keep writing and rewriting the same scenes over and over.


I have Storyist version 3.4.3 and OS Yosemite 10.10.2.


Thank you in advance.

Share this post

Link to post
Share on other sites

Ah, so sorry to hear that. How annoying indeed! Perhaps it's something simple we ca figure out.


Try the following: create a new project, save it somewhere safe (Dropbox for example), and make a change. Close the project, close Storyist, then open up the project again and make another change. Close Storyist again, and re-open. Have your changes been saved?


If yes, that's a good start. Now see if perhaps your original project was saved somewhere else. Mine are in Dropbox, in a folder called Apps/Storyist (I believe the iOS version set this up as a default, so I stuck to this for my Desktop version too). Have a look at your recent files too (under File - Open Recent) and see if you've saved your project in multiple locations. Could be as simple as you've got a previous writing effort stashed somewhere else accidentally.


One last thing to check (and know about): are you using Storyist for Mac and the iOS version side by side? If so, it could be that your project was simply overwritten by an older version from either the Desktop or iOS. The way it works between multiple devices is that "the last writer wins", no matter what changes are active. What can happen is that you open the iOS version for a correction or quick addition, put the app in the background and forget about it, then pick up your laptop and wonder where that last change has gone. It may still be there, because the project is still open in iOS but it hasn't saved yet. So you re-write the scene on your desktop. But now neither version is in sync, because iOS hasn't saved to dropbox until you close the project.


When working across multiple devices (Laptop - Desktop - iPhone - iPad), it's absolutely vital that you save and close your project once you're done making changes. All devices need to be connected to the internet for the changes to populate across all devices for trouble-free syncing.


That's what I would check. Hope you can find those missing pages!

Share this post

Link to post
Share on other sites



I tried the new project as suggested and that worked. However, when I went back and worked on my old project again, the changes didn't save once again.

(I did save the scene I wrote elsewhere.)


I only have and use Storyist on my laptop.

Share this post

Link to post
Share on other sites

Bizarre stuff indeed.


Perhaps your project file is corrupt, or there's a file permission problem. Try duplicating it in Finder, then open the copy and try to save some changes there. If that works, something's amiss with the original.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this