Jump to content
Storyist Forums

Storyist 4 Not compatible with Storyist 3


Recommended Posts

I was running V3 on my 2009 Desktop Mac and my 2019 MacBook Pro Sonoma v14 - I upgraded MacBook to V4

Novel for past months saved to iCloud - today accessed iCloud on laptop to work

1. the file downloaded 'blank'

2. copied file from Desktop files to Laptop - still blank

3. Shutdown and restarted computers - still blank

4. Downloaded and loaded V3 onto MacBook Pro running Sonoma v14 -

Pop Up Box  - Storyist Trial    -— "Please install your Storyist 2 Licence too. Storyist found your Storyist 3 upgrade licence, but did not find a licence for Storyist 2"

I no longer have a copy of my Storyist 2 licence as it was kept on a computer and backup damaged. The files with those passwords and licences for a number of programs that no longer exist. 

I have a considerable amount of work I now cannot access on my laptop what is the fix please

Link to comment
Share on other sites

Hi Barynz,

The file format didn't change between Storyist 3 and Storyist 4, and Storyist 4 can open files from older versions.

I'm happy to help you troubleshoot. Please send a brief email to support@storyist.com with a little more information on what you're seeing. It would be helpful to know:

  • What versions of macOS and Storyist are you running on the 2009 desktop?
  • What version of Storyist are you running on the 2019 laptop?
  • Did the issue on the laptop occur before you updated to Sonoma? (Sonoma has some bugs, and Storyist 4.3.1 has some workarounds for them.)

It would also be helpful to know a little more about what looks 'blank'. I'm assuming that you can open the projects and that you can see the files in the project view, but that the text is empty. If that's not the case, let me know what you're seeing. A screenshot would be helpful.

I can also look up your Storyist 2 license if you purchased it after 2011.


Link to comment
Share on other sites

Hi Steve, 

Problem regarding not able to read file on laptop is solved—I put it here because I'm sometimes a bit of an F-Wit by looking at the complicated methods rather than the basics. Mind you I would not have found it if I hadn't read a similar problem on and IOS phone. I tried reducing the screen and then discovered, for some reason—probably at my end—the "Project View was closed. On opening the Project View the screen was still grey until I actually (yeah) clicked on the first chapter and all appeared.

As in my post, I am running:

Version 3 on my 2009 Mac Desktop (not at home at present so unable to say what OS Version, but it is the last one the 2009 models could update.

Version 4 on my 2019 MacBook Pro I am running MacOS Sonoma v14.

I believe I purchased Storyist somewhere around 2014. Pretty sure it was Version 3 - I have no licence details as I lost a lot of emails on which the licence details were stored on, so if it is possible to forward same it would be great.

Love the program and have used it extensively since purchase and will forward this by email.

Again, thanks so much for your prompt response, I bashed out the above in panic as my transport arrived, the support is another great aspect of the program.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...